f
s
All games Skyforge In-game Issues

Invasion Card: Table of Equipment Inaccuracy

Our team has located a discrepancy with the Table of Equipment and we are working to correct this as quickly as possible. The current version of the Table of Equipment inaccurately displays the Required Prestige level was 181 Prestige for participating in the following zones:

 - Tarlen Aquifer (New Prestige Requirement: 193),
 - Kuat-Lien Station (New Prestige Requirement: 193), 
 - Fort Darlek (New Prestige Requirement: 193),

Thank you for your patience while we work to correct this issue.

If you have any questions,
you can submit a ticket to the technical support team.

Account Issues

General Inquiries

In-game Issues

Invasion Card: Table of Equipment Inaccuracy

myLoot Shop

Overgrowth & Grovewalker FAQ

Payment Issues

Privacy Policy

Technical Questions

Website and forum issues